Home Forums ePix Support Portfolio setup

Viewing 15 posts - 1 through 15 (of 30 total)
  • Author
    Posts
  • #62199

    Vladimir
    Participant

    Hello. I still try to setup my site. In this time I have trouble with portfolio.
    I make new portfolio item, with featured image and set a category

    After I make new page and via VC insert code for grid-gallery:
    [vc_row][vc_column width="1/1"][postgallery_grid id="grid_portfolio-en" data_source="data-6" categories="" slidesetid="" portfolio_categories="Man,People" orderby="ASC" content_type="textimage" columnpadding="" filtering="yes" masonry="masonry" align="aligncenter" lightbox="" zoomhover=""][/vc_column][/vc_row]

    And now:
    On portfolio page I see filter by category only, no any portfolio item
    On portfolio item page I see featured image and portfolio page content

    I make something wrong?

    #62223
    Andy
    Andy
    Keymaster

    Hi,

    Can you post your WP login details please ( click “Set as private reply” ) and I’ll investigate for you.

    #62227

    Vladimir
    Participant
    This reply has been marked as private.
    #62230
    Andy
    Andy
    Keymaster

    Hi,

    It’s to do with the category slugs, WordPress automatically converts Russian characters – So your portfolio slugs become muzhchiny and lyudi. Because of this, I had to goto the Porfolio page > Click Switch to Classic view and locate the within the shortcode the following line: portfolio_categories="" and change the portfolio categories to muzhchiny,lyudi

    This unfortunately is the way you’ll have to do things. Ensure that the portfolio_categories="" mataches the slugs of the Portfolio Categories.

    I hope that makes sense?

    #62233

    Vladimir
    Participant
    This reply has been marked as private.
    #62236

    Vladimir
    Participant
    This reply has been marked as private.
    #62283
    Andy
    Andy
    Keymaster

    Hi,

    One way that may work instead is to use the Category ID instead, so edit the Gallery and change the portfolio_categories="" to the ID’s of the categories instead?

    #62290

    Vladimir
    Participant
    This reply has been marked as private.
    #62329
    Andy
    Andy
    Keymaster

    Hi,

    I’m not sure if we’ve confused ourselves. Usually the translation does work with Posts, Portfolio etc. I think the initial issue with the mismatched Portfolio Category slugs was the issue.

    I’m not sure what the best method is, but I’m sure you’ll need to create the Russian equivalent of “Girls” & “Men” categories in Portfolio > Portfolio Categories and on the Russian version of the “Portfolio Test”, select the Russian Categories?

    Can you try that please and let me know if that works. Once you’ve created those categories, I can check to see what is happening.

    My apologies about this, I’ve not had any reported issues before and I’ve seen plenty of translated sites, therefore I assumed all was fine.

    #62330

    Vladimir
    Participant
    This reply has been marked as private.
    #62337
    Andy
    Andy
    Keymaster

    Can you provide your FTP details too please, I want to resolve this for you – I’m not sure if it’s because the Russian characters are completely throwing the WP database off because of the slug. If that’s the case, I’ll need to write extra code to look for the slug instead.

    #62339

    Vladimir
    Participant
    This reply has been marked as private.
    #62354
    Andy
    Andy
    Keymaster

    Hi,

    I believe I’ve resolved this now, please see here: http://www.agapof.com/portfolio/

    #62359

    Vladimir
    Participant
    This reply has been marked as private.
    #62406

    Vladimir
    Participant
    This reply has been marked as private.
Viewing 15 posts - 1 through 15 (of 30 total)

You must be logged in to reply to this topic.

© 2019 Acoda