Home Forums ePix Support Post a Comment showing Twice

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #62120

    Kim Townsend
    Participant

    When a user is not logged in to the admin and on an individual post, the bottom says, “You must be logged in to post a comment.
    Profile
    You must be logged in to post a comment.”

    Why is this showing twice?

    #62156
    Andy
    Andy
    Keymaster

    That’s very interesting, I’ll investigate and come back to you. Do you have a link too?

    #62170

    Kim Townsend
    Participant
    #62171

    Kim Townsend
    Participant

    Oh and the login is still the same from the other thread of mine 🙂

    #62178
    Andy
    Andy
    Keymaster

    Hi Kim,

    It’s actually coming from the “social” plugin and not the theme.

    #62179

    Kim Townsend
    Participant

    How weird. Can I disable that in the theme and let social take over? I’ve used this plugin for years and never had any issues…I should add *that I know of* LOL

    • This reply was modified 4 years, 6 months ago by  Kim Townsend.
    #62219
    Andy
    Andy
    Keymaster

    You could use a bit of CSS to hide one of them. e.g.

    #respond p.must-log-in {display:none;}

    #62404

    Kim Townsend
    Participant

    So I added that code and made sure comments were OFF in the theme options, and now the whole comment form is showing. I went into the Settings>Discussion and turned off the commenting. Thoughts?

    #62436
    Andy
    Andy
    Keymaster

    Do you have this option disabled in Settings > Discussion “Allow people to post comments on new articles “. Also, individual posts can override this option, goto the post > screen options ( top right ) and enable discussion, this should show a discussion box and you’ll be able to enable or disable discussions.

    #62443

    Kim Townsend
    Participant

    Everything is disabled in the settings. I’ll check per page and see. Thanks!

    #62444

    Kim Townsend
    Participant

    Everything is disabled:
    Screenshot 1

    Screenshot 2

    #62450
    Andy
    Andy
    Keymaster

    That’s so strange, have you checked to see if a plugin isn’t overriding this and I can’t remember if you’re using cache, but cleared that too?

Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.

© 2019 Acoda