Home Forums ePix Support Warning: Illegal string offset

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #48677


    Hi, I have updatet my php-version to 5.4 and now my site is upsolutly not working and I get the following error-massages:

    Warning: Illegal string offset ‘type’ in /homepages/14/d462367966/htdocs/shop/wp-content/plugins/js_composer/composer/lib/mapper.php on line 129

    Warning: Illegal string offset ‘param_name’ in /homepages/14/d462367966/htdocs/shop/wp-content/plugins/js_composer/composer/lib/mapper.php on line 132

    Warning: Illegal string offset ‘param_name’ in /homepages/14/d462367966/htdocs/shop/wp-content/plugins/js_composer/composer/lib/mapper.php on line 134

    This warnings are repeating many times.

    I have the newest epix-version and visual composer 4.1.3.

    Thanks for Help!



    Tom ( Support)

    Hi Alexe,

    It seems you are not using the latest stable version of Visual Composer. You may have issues with it as the official un-modified VC versions have a lot of bugs in. The themeva version bundled with the theme has extra options and is stable.

    To downgrade to the stable version, first make sure you are using the latest version of ePix then go to Plugins > Deactivate VC > Delete it > Admin notice at the top of the WP Admin, click install Visual Composer > You should now have the latest version.

    For the mapper issue, please see this post here. PHP 5.4 shows up warning as text instead of putting it into a log, very annoying to say the least!

    Kind regards,



    Thanks a lot, now it works and Iam happy. I really love this theme.


    Tom ( Support)

    Thats great, thank you for coming back to us.

    If you are happy with the theme, please take a second to rate the theme 5 stars here.

    Much appreciated 🙂

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

© 2019 Acoda