Home Forums ePix Support Website loads slow

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #104444

    Sujal Patel
    Participant

    Hi Guys,

    Apologies for reaching out yet once again – but i’ve just asked a few people to test out the website and the one thing that keeps coming back to me is that it takes a really long time for the site to load?

    i’ve run the EWWW Image optimiser.

    The images that i Load on to the site are by default 1800px by 1200px (as suggested by someone on the forums) Are you able to help me further optimise it or suggest what else I can do to speed up the site?

    Many thanks
    Sujal

    #104452
    Edcel
    Edcel
    Moderator

    Hi @darksouljah

    Your site is 42MB in size. That alone will drag the site’s load time.

    A well-optimized site should stay under 2MB while your site is 20x more than that recommended size.

    Please optimize the images you are using on your site. There is no need to show images that are 1800px in width specially on web. If you want to use 1800px width images, then you must still compress the images for web.

    Also, it is best to coordinate with your server provider for further issues on the speed as this is not related to the theme.

    Regards,

    #104488

    Sujal Patel
    Participant

    Thanks Guys – ive now optimised my site so that the images on the home screen at 1600px and have also reduced the quality of it..

    Also – looking at using Cloudfare – for CDN, ive hear it should help speed up my website. 🙂

    Thanks again for all your help.
    Sujal

    #104490
    Edcel
    Edcel
    Moderator

    Hi @darksouljah

    Yes, CDN should help speed up the site specially since your site is mostly using images, which are static content and can be easily cached by the CDN.

    Regards,

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

© 2018 Acoda