Home Forums ePix Support WooCommerce – product & menu issue

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #43878

    Wild Rice
    Participant

    Hi ,
    love the theme so thanks !
    but i am having an issue with the WooCommerce integration in relation to products –
    when i click on a product and bring up that page i get the menu 3 times , and i can for the life of me work out how or what i need to turn off in order for it only to show the custom menu i have set up
    see example here
    http://www.mrmrsrice.com/product/alessi-kitchen-clock-designed-by-michael-graves/
    as apposed to
    http://www.mrmrsrice.com
    can you shed some light on the issue
    many thanks

    #43893

    Tom ( Support)
    Keymaster

    Hi,

    I have not seen this before and that is definitely not standard theme behaviour. I recommend de-activating each of your plugins one-by-one to find one that may be conflicting.

    Kind regards,
    Tom

    #44083

    Wild Rice
    Participant

    Hi Tom ,
    thanks for your speedy reply , i have done as you asked but alas it has not fixed the issue – it seems to stem form the WPcustom menu being activated. I deactivated it and the issue went away – problem is i don’t wish to display all my pages in the Menu (hence the use of the WPcustom Menu)
    so my question is – is the epix theme actually compatible with both the WooCommerce & WP Custom Menu as stated in the temeforrest description and if so what is going wrong with my site?
    truly do love your theme and really want to get the issue sorted!

    kind regards

    #44097

    Tom ( Support)
    Keymaster

    Hi,

    Have you turned responsive off on your theme? If so, you will need to add this section of code to correct the menu.

    #mobilemenu {
    display:none;}
    

    For reference, this was added to Appearance > Theme Options > Customize > Custom CSS.

    Both are compatible with the theme, see the ePix demo site for this.

    If you are still having issues, please set your reply to private and provide your URL/login details so I can take a further look for you.

    Kind regards,
    Tom

    #44215

    Wild Rice
    Participant
    This reply has been marked as private.
    #44222

    Tom ( Support)
    Keymaster

    Hi,

    Since when did you menu not appear on your site correctly? It seems that you have added a custom menu within your widgets to get the menu to show. This should not be the case as it should get added in automatically.

    You also have a non themeva version of Visual Composer which could be what is causing this issue. Currently were are a lot of bugs with the new release, hence why there has been no update released with the theme yet. One will come out soon after extensive testing has been completed.

    To go back to the stable themeva version, please de-activate VC, delete it, go to Appearance > Install plugins, install VC then it should be back to normal.

    Please let me know if your menu appears after that.

    Kind regards,
    Tom

    #44230

    Wild Rice
    Participant

    Hi tom
    It has always had the issue pre updated page builder
    I want to control how the shop looks so I have hidden the woo commerce shop pages and built individual pages with a grid gallery to display the products as you can see it’s only when you select a product that you get the doubling of the custom menu in he menu side bar
    If I remove the custom menu in the widget section the entire menu disappears ?
    Thanks for you help I look forward to your reply

    #44282

    Tom ( Support)
    Keymaster

    Hi,

    So when you first installed the theme, the menu would not show? Or have you edited the core code at all to prevent this from happening? Do you mean before you updated Visual Composer, you still had this issue?

    The menu should be there regardless and shouldn’t need to be added by the custom menu widget at all. If we can solve the original menu issue, it will solve the duplication.

    Kind regards,
    Tom

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.

© 2019 Acoda